PetPoint Enhanced Support Chat Outage

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2026 - 10:45 EDT

Investigating

We have received reports that the PetPoint Enhanced Support Chat option is currently missing from the Contact Us page.
Our team is actively investigating the issue, and updates will be posted here as they become available.
At this time, the Enhanced Support Phone line and all case submission forms remain fully operational and unaffected.

Thank you for your patience and understanding.
Posted May 12, 2026 - 18:13 EDT
This incident affects: Support Options (PetPoint Support).