PetPoint Builder Performance Issue

Incident Report for Pethealth Software Solutions

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 15:02 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 15:32 EDT

Investigating

Access to PetPoint Enterprise Builders is currently unavailable or experiencing technical difficulties. We are investigating the cause for this and will provide an update as soon as possible.
Posted Apr 24, 2025 - 14:58 EDT
This incident affected: PetPoint (Builders Add-On).