Pet Professional Portal Outage

Incident Report for Pethealth Software Solutions

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 10:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 09:15 EDT

Investigating

The Pet Professional Portal is currently experiencing an outage. We are investigating the issue and updates will be posted here as they become available.

Thank you for your patience.
Posted Mar 17, 2025 - 14:45 EDT
This incident affected: 24Pet (Pet Professional Portal).